Zabbix 清理过久的历史信息
当我们的zabbix运行时间久了,监控的节点多了,数据信息会增长的很快,想备份里面的数据库时,要浪费大量的时间,zabbix里面最大的表就是历史记录的表了,网上很多人都是写全部清空这些表的数据,其实我们可以按时间来删除里面的历史记录; 里面最大的表是 “history” 和 “history_uint”两个表; zabbix里面的时间是用的时间戳方式记录,我们可以转换一下,然后根据时间戳来删除; 比如要删除2012年的11月25号以前的数据 1、先将标准时间转换为时间戳 # date +%s -d “2012-11-25 00:00:00”1353772800 2、mysql清理数据 mysql> use zabbix;mysql> DELETE FROM `history_uint` WHERE `clock` < 1327939201;mysql> optimize table history_uint; 注:执行过第二行命令之后可能会需要很长的一段时间,中间不要K掉了,否则容易丢失数据的。
LVS+Keepalived
说明: 本文档仅围绕lvs+keepalived如何实现负载均衡、故障剔除、后端realserver健康监测、主备切换邮件通知;而防火墙、网络(路由交换)、后端数据存储、内外网暂未考虑; 一、环境准备: 1.操作系统 CentOS6.4-x86_64 2.软件版本: ipvsadm-1.25-10.el6.x86_64keepalived-1.2.7-3.el6.x86_64httpd-2.2.15-26.el6.centos.x86_64 3.实验拓扑: 4.时间同步: 123456789101112node1:\[root@node1 ~\]# ntpdate 203.117.180.36\[root@node1 ~\]# echo "*/10 * * * * /usr/sbin/ntpdate 203.117.180.36" >> /etc/crontabnode2:\[root@node2 ~\]# ntpdate 203.117.180.36\[root@node1 ~\]# echo "*/10 * * * * /usr/sbin/ntpdate 203...
Tomcat环境搭建及jsp站点实现
安装JDK(配置java环境): 环境:CentOS6.5_x86-64bit 一、先安装JVM 1.使用7版本的jdk(到官网下载相应的软件包到本地http://www.oracle.com/technetwork/java/javase/downloads/java-archive-downloads-javase7-521261.html#jre-7u9-oth-JPR) [root@localhost ~]# rpm -ivh jdk-7u9-linux-x64.rpmPreparing… ########################################### [100%]1:jdk ########################################### [100%]Unpacking JAR files…rt.jar…Error: Could not open input file: /usr/java/jdk1.7.0_09/jre/lib/rt.packjsse.jar..Error: Could not open in...
Snmp协议详解
监控主机的方式: 1.基于通行的snmp 2.基于专用agent 3.基于ssh(shell) 对于不同的监控指标,最后实现的功能也有所不同.下面是本人通过学习总结关于与snmp协议的一些解释以及运用 SNMP 主要几个简单的操作就可以实现对远程设备上的服务、资源等各种系统状态信息的获取,不仅仅是获取信息这么简单,还能在达到我们设定值或状态状态发生转换时能向对方发送控制指令; SNMP的工作机制: 监控端/一个或多个被监控端 监控端:NMS,这个平台会为管理员提供命令行接口,可以发送snmp指令到任何一个被监控主机,而在被监控端安装了一个服务进程,它用于接收来自监控端的查询请求, 并且能够解析对方的查询请求,并将查询数据返回给对方,所以这个服务进程可以称之为是一个agent,它只是接收一些查询或者是管理指令而存在的; 监控端发送请求—>agent接受请求(根据查询请求内容)—>agent返回查询请求到监控端. 但是上面有个弊端,也就是说任何主机连接到我们的agent就可以发送指令,这样一来安全方面就有了很大的隐患,于是在此基础上面就引入了communities在监控端...
Perl: Warning: Falling Back to the Standard Locale (“C”)
今天在安装memcache的php的扩展时遇到的错误: 1.将该扩展包解压 2.使用/usr/bin/phpize(rpm包安装后的位置)命令来准备 PHP 外挂模块的编译环境(如果找不到该命令则需要安装,这个命令有php-devel这个包生成,并且该包位于DVD2中) 上面1、2步成功 3.使用/usr/bin/phpize时报以下错误: [root@node1 memcache-2.2.5]# /usr/bin/phpizeConfiguring for:PHP Api Version: 20090626Zend Module Api No: 20090626Zend Extension Api No: 220090626perl: warning: Setting locale failed.perl: warning: Please check that your locale settings: LANGUAGE = (unset), LC_ALL = (unset), LANG = “en” are support...
Vmware Clone陷阱
在我们平时使用vmware workstation做实验时,会遇到主机不够用的情况,那此时我们的解决办法一般都是要么从新装一台新的,要么就是通过vmware workstation强大的克隆功能克隆出我们需要的虚拟机;显然后者的优势比前者大,毕竟你从新装一台的话占用你的物理硬盘空间,其次就是浪费Your Time. SO,就选择Clone吧. 我现在有一台刚装好的虚拟机(母机),由于做实验我需要多台主机;我将这台主机命名为node1,目的是通过这台母机克隆一台虚拟机node2; 在Clone Type页中,单击Create a linked clone(创建一个克隆链接)。如果选择第二项Create a full clone,则创建一个完整的克隆。这两个区别在于:第一项创建的虚拟机将依赖于源虚拟机的存在,使用这项创建的虚拟机占用较少的硬盘空间;第二项创建的 虚拟机是一个独立的虚拟机,但占用较多的硬盘空间。我这里选择的是Create a linked clone,具体的步骤我就不再给出; node2通过node1不到10s就克隆好啦,但是待我查看克隆出来的两台机子的网络信息时居然不...
获取Linux服务器硬件信息
1.查看服务器型号、序列号: [root@localhots ~]#dmidecode|grep “System Information” -A9|egrep “Manufacturer|Product|Serial” Manufacturer: HP Product Name: ProLiant DL360 G6 Serial Number: JPT0012J2W 2.Linux 查看内存的插槽数,已经使用多少插槽.每条内存多大: [root@localhost ~]#dmidecode|grep -A5 “Memory Device”|grep Size|grep -v Range Size: No Module Installed Size: No Module Installed Size: 4096 MB Size: No Module Installed Size: No Module Installed Size: 4096 MB Size: No Module Installed Size...
如何让计划任务实现秒级执行
最近有个应用需求,根据实际要求最好是每3秒执行一次,但是crond只能支持到分。这该如何是好? 第一种方法: 首先想到的是通过一个触发的脚本,然后在脚本中使用死循环来解决此问题,如: cat test.sh----------------#!/bin/bashwhile : ;do /home/script/test.sh 2>/dev/null & sleep 3done---------------- 注意第一次运行时请不要使用sh test.sh & 这种后台运行的方式,它会僵死的。 可以把它放到计划任务使其运行,然后将计划任务中的此条目删除即可。最后把这个脚本放到/etc/rc.local让它每次开机都可以被运行。 第二种方法: 和第二种方法类似,但是比起来更便捷一些。 cat cron-seconds.sh----------------#!/bin/bash#For excuting the scripts every 3 seconds in crond. for((i=1;i<=20;i++));d...
Zabbix Server Is Not Running:错误的解决
今天在安装了zabbix-server端后 在zabbix的dashboard中中出现下面的信息: 随即检查了zabbix-server的运行状态和mysql的运行状态都是正常的;困扰有半刻钟左右,将所有的配置文件检查了一遍 发现在/etc/zabbix/web/zabbix.conf.php 中有这么一行信息: 解决: 我将”ZABBIX-SERVER” 改成了我的zabbix-server的IP.保存退出、重启zabbix-server、刷新dashboard;恢复正常啦! 问题原因: 我从新安装了一次,发现在dashboard界面安装过程中,我将host的名称给自定义了, 它默认是”localhost”,这里根本就不需要修改,默认就行啦! “Name”倒是怎么方便怎么来。 比较重要的文件就是/etc/zabbix/中的那一堆了;日志文件的话都在/var/log/zabbixsrv/下面. 还有一些错误倒是能根据一些提示解决,比如/etc/php.ini中的好几个参数需要修改,按照提示修改完,重启一下apache就ok!
Linux上ip归属查看神器
nali取名”哪里”的拼音。 nali包含一组命令行程序,其主要功能就是把一些网络工具的输出的IP字符串,附加上地理位置信息(使用纯真数据库) 例如218.65.137.1会变成218.65.137.1[广西南宁市 电信]。 查询是在本地进行,并不会进行联网查询,所以效率方面不会有什么影响。 目前包含以下几个命令: nali nali-dig nali-nslookup nali-traceroute nali-tracepath nali-ping 使用这些命令的前提是,他们对应的命令必须存在。例如你要用nali-dig,必须保证dig是存在的。他们的用法和原始命令是一样的。例如nali-dig,用法就和dig一样。 大家可能注意到了nali这个命令,它可以对标准输出的IP串附加上地理信息。nali-*系列工具都是基于这个来实现的。 下载 wget http://www.sctux.com/package/nali-0.1.tar.gz 安装 ./configure –prefix=/usr && make && make instal 使用 1...
Nagios-NRPE脚本返回值
自定义Nagios NRPE脚本EXIT退出值和nagios状态都应关系: 状态 EXIT退出值 输出 例子 OK 0 echo “OK - it’s ok.” echo “OK - it’s ok.” exit 0 WARNING 1 echo “WARNING - it’s warning.” echo “WARNING - it’s warning.” exit 1 CRITICAL 2 echo “CRITICAL - it’s critical.” echo “CRITICAL - it’s critical.” exit 2 UNKNOWN 3 echo “UNKNOWN - it’s unknown.” echo “UNKNOWN - it’s unknown.” exit 3 错误的例子: shell脚本中echo和退出值: echo “OK - it’s ok.” exit 1 此时,Nagios会显示: 这条服务对应的状态是”WARNING“,但是输出的信息是”OK - it’s ok.”
Vsftp 开启 PASV模式
今天应老大要求要在一台在公网的机器配置一个vsftp服务,配置好之后居然不能用,甚是纳闷,具体报错如下图: 1、我在本机 ftp localhost 却一点没有问题? 2、为什么一出外网就有问题? 3、这台服务器在公网,在防火墙后面,本机iptables是停了的; 4、以前都是在内网,甚至是同一个网段搭建vsftp来使用; 5、vsftp的配置非常的简单,难道还有些地方有疏漏? 解决方法: 1、在/etc/vsftpd/vsftpd.conf末尾添加: #YES,允许数据传输时使用PASV模式。NO,不允许使用PASV模式。默认值为YES。pasv_enable=YES #设定在PASV模式下,建立数据传输所可以使用port范围的下界和上界,0 表示任意。默认值为0。把端口范围设在比较高的一段范围内,比如50000-60000,将有助于安全性的提高.pasv_min_port=30000pasv_max_port=30005 #此选项为一个数字IP地址,作为PASV命令的响应。默认值为none,即地址是从呼入的连接套接字(incoming connectd socket)中获取...